This browser does not have a Java Plug-in.
Get the latest Java Plug-in here.

www.liaworks.com

proximityOfNeeds.jar